Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

dana 60 warn hub problem ?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by dewster, Nov 5, 2005.

  1. dewster

    dewster Registered Member

    Joined:
    Jul 21, 2003
    Posts:
    31
    Likes Received:
    0
    Location:
    corona ca >> austin,tx
    im sure this probably has been answered, couldn't find it. today was replacing stock dana 60 hubs with warn new ones, and the warn ones wouldnt go far enough in to install the clip and lock on the outside. so took back off and noticed another snap ring farther back on the outer axle shaft, right infront of the 2nd wheel bearing nut. removed the snap ring and warn hub went right on no problem. allowing enough room to install outer snap ring and large diameter lock. is this normal, looked at diagrams and cant tell if both snap rings are needed. ??????????? thanks
     
  2. sapper

    sapper 1/2 ton status GMOTM Winner

    Joined:
    Jul 11, 2001
    Posts:
    3,052
    Likes Received:
    0
    Location:
    NoVa
    Are you talking about the small one on the shaft? If so just take a long screwdriver and at the joint push the axle out, there is about a 1/4 inch of play, if its pushed in the ring wont go on.
     
  3. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    Yes some axles had the 2nd snap ring close to the end of the spindle, To run the warn hubs it is required to be removed. You only need the outer one.
     
  4. dewster

    dewster Registered Member

    Joined:
    Jul 21, 2003
    Posts:
    31
    Likes Received:
    0
    Location:
    corona ca >> austin,tx
    thanks

    appreciate it. that is what i thought.
     

Share This Page