Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Dash lights went out?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by LucasJ03, Oct 5, 2004.

  1. LucasJ03

    LucasJ03 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    289
    Likes Received:
    0
    Location:
    Ft. Fun, Colorado
    All my cluster light went out including my locker switches,everything that is on the cluster fuse. The fuse is good but it almost seems like it's not getting power at the fuse box. Has anyone had this promblem? If so how did you fix it.

    Thanks
    Lucas
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,977
    Likes Received:
    189
    Location:
    Roy WA
    Check if the fuse is actually getting power, that will narrow it down for you. Test light or multimeter. Have the key on "run" though, since that circuit is not doubt an "ignition 12V" one.
     
  3. LucasJ03

    LucasJ03 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    289
    Likes Received:
    0
    Location:
    Ft. Fun, Colorado
    I'm not getting any power at the fuse box that's the wierd part.
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,977
    Likes Received:
    189
    Location:
    Roy WA
    Is this the '90?

    Don't have my wiring manual right next to me, but is anything else not getting power?

    Typically those fuse terminals use a copper strip (extremely unlikely to be damaged) on the back side of the panel that connects the fuses above and/or below the one in question, so those SHOULD be dead as well. There should be a few shunts on the circuit panel, as well as a circuit breaker that feeds at least some of the fuses.

    Whatever you used to test, you did ground it to the body somewhere good, and tested both of the blade terminals in the fuse cavity, correct?
     
  5. LucasJ03

    LucasJ03 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    289
    Likes Received:
    0
    Location:
    Ft. Fun, Colorado
    yes it is a 90. My tester was fine I have power at all the other fuses just not that one. My brake light, check engine light and all those red lights come on when I start it like every truck does and my blue dot for my brites work just not the illumination lights on the dash.
     
  6. 70~K5

    70~K5 1/2 ton status

    Joined:
    Apr 13, 2002
    Posts:
    2,032
    Likes Received:
    0
    Location:
    sillycon valley
    Check the dimmer circuit in the switch.
     

Share This Page