Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Dead Battery

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by inaminute5150, Sep 28, 2002.

  1. inaminute5150

    inaminute5150 Registered Member

    Joined:
    Apr 16, 2002
    Posts:
    15
    Likes Received:
    0
    Location:
    west coast California Vacaville
    <font color="blue"> </font color> I have an 89 full size Blazer, I happen to walk near the rear and heard this buzzn noise ,being that there really isn't anything electrical in the area so i assumed it was the fuel pump!I hopped in and started it up,starts right away didn't think much of it at the time.To make a long story short, came out the next a.m found the battery deader than a church house mouse!!!Amagine my shock.Well took the battery to local parts,they test and explained that i need a new battery as this is beyond F.U.B.A.R!!!!!!!First ? is as to why would the pump keep running ,even with the ignition in the off position? Second if it wasn't the fuel pump,what could've been making the buzzin noise from the rear,even with everything off what could it been? Also is this a common Problem? /forums/images/icons/confused.gif
     
  2. tipoil

    tipoil 1/2 ton status

    Joined:
    Jul 30, 2002
    Posts:
    222
    Likes Received:
    0
    Location:
    canada guebec
    rear window motor??? maybe!!!

    hope it helped a bit!!
     
  3. trouble1

    trouble1 1/2 ton status

    Joined:
    Sep 28, 2002
    Posts:
    346
    Likes Received:
    0
    Location:
    travelling, probably lost
    Even if something would have been running, that should not have killed the battery, drained it,yes...killed it, no. /forums/images/icons/confused.gif
     

Share This Page