Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Dies at idle and wont start back up???? Please help

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Delay, Feb 24, 2003.

  1. Delay

    Delay Newbie

    Joined:
    Nov 25, 2002
    Posts:
    2
    Likes Received:
    0
    Location:
    Portland OR
    I have an 89 k5 blazer with a fuel injected (TBI)350. My problem is the dies at idle and wont start back up, its usauly after its warmed up but it has done it while its cold. It cranks fine but just wont start. If you let it sit over night or at least a few hours guaranteed the thing will start back up. When you try to start it after it dies there is no injector pulse, i hooked a noid light up and there is no current (light doesn't flash). It has a brand new fuel pump (in tank), new fuel filter, new fuel pump relay and a new EGR solenoid. It also has a fairly new alternator. Sometimes at idle it wants to lurch forward, its pretty random. Please help! Thank you very much to anyone that can help me out with this.
     
  2. DukeBoy88

    DukeBoy88 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    315
    Likes Received:
    0
    Location:
    Jonestown Pa
    I hate tracking problems like this down, I remember something simular and I ended up unwrapping my harness looking for shorts. after that I replaced several pieces and I believe after I replaced my Ignition control module (use gm only) it went away. whether or not that fixed it I'm not sure. I've had gremlins dissapear on there own before.
     

Share This Page