Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Dim lights at idle?

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by Col_Mustard, Jul 8, 2001.

  1. Col_Mustard

    Col_Mustard Newbie

    Joined:
    May 6, 2001
    Posts:
    4
    Likes Received:
    0
    When my '72 Blazer comes down to an idle, like at a stop light, the headlights & dash lights get much dimmer. The light brightness seems directly related to the speed of the engine. Anyone know why the lights go dim at idle? The engine is a 350 w/ a stock alternator.
     
  2. Fish

    Fish Registered Member

    Joined:
    Jul 5, 2001
    Posts:
    34
    Likes Received:
    0
    Location:
    Michigan
    Do you have any high draw electrical items on the truck? Maybe the alternator can't keep up. How old is your battery?
     
  3. Col_Mustard

    Col_Mustard Newbie

    Joined:
    May 6, 2001
    Posts:
    4
    Likes Received:
    0
    Thanks for the response. There are no additional electrical items. There is an Optima red top battery 2-years old in the Blazer.
     
  4. Fish

    Fish Registered Member

    Joined:
    Jul 5, 2001
    Posts:
    34
    Likes Received:
    0
    Location:
    Michigan
    Well, I guess I've got one more idea, check the tension on the belt for the alternator. It could be slipping. I've also heard of this happening with chrome parts. The belts slips in the pulley, and you don't get a good charge.
     
  5. Klef72K5

    Klef72K5 1/2 ton status

    Joined:
    Apr 8, 2001
    Posts:
    249
    Likes Received:
    0
    Location:
    Columbia City, Indiana
    what's the altenator charging at? I had this problem with my 69 Roadrunner and it was the altenator. It could even be the regulator that is bolted on the fire wall if it's the original style altenator. I would check both.

    <A target="_blank" HREF=http://wsphotofews.excite.com/031/rw/Jo/og/t488200.jpg>http://wsphotofews.excite.com/031/rw/Jo/og/t488200.jpg</A>
     
  6. Steve_Chin

    Steve_Chin 1/2 ton status

    Joined:
    Mar 6, 2001
    Posts:
    1,126
    Likes Received:
    0
    Location:
    Foster City, CA, USA
    Do you have underdrive pulleys on your engine and accessories? At what RPM is the engine idling?

    If everything is stock, I would suspect that the alternator has an open circuit in a winding or one of the rectifers.
     

Share This Page