Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Dont know what, but somethin is broke

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by tecton, May 13, 2003.

  1. tecton

    tecton 1/2 ton status

    Joined:
    Dec 1, 2002
    Posts:
    1,553
    Likes Received:
    0
    Location:
    WV
    Noticed this today...friend and i were testing my flex...stuff and flex to be precise...well after this i drove him to work and i myself went onto work and when pulling in...i made a sharp left turn and noticed soemthing....

    it feels like....at first it felt like the rear driverside wheel was dragging...over the course of the evening its developed into a few other possibilities...mabye the front wheels are tryin to spin when i turn...mabye a u joint is broke....diff grese needes changes...posi trac fluid needs changed...

    theories...
    Hubs broke and wont disengage...
    4X4 is still engaged
    rear diff clutches are sticking, needs re-greased...any ideas?
     
  2. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    I would think of 2 things. 1. 1 hub didn't disengage. 2. You busted a govlock.
     
  3. tecton

    tecton 1/2 ton status

    Joined:
    Dec 1, 2002
    Posts:
    1,553
    Likes Received:
    0
    Location:
    WV
    when i steer left, thing wants to turn right really fast if i left off the wheel...and its steering weird also...
    we got under there and the little rubber hose coming out of the read diff where its latched up under the body there is like grease all over the metal up there...like its been spewing (known of this for sometime)
     
  4. Seventy4Blazer

    Seventy4Blazer 3/4 ton status

    Joined:
    Apr 21, 2001
    Posts:
    5,634
    Likes Received:
    0
    Location:
    Escondido, CA
    try backing up for about 35 feet, that is if you have autp hubs. if you have manual hubs, or that dotn work, pull the hubs appart, clean and regrease them and replace broken parts if any(but im sure ya knew that) and re install them.
    Grant
     
  5. tecton

    tecton 1/2 ton status

    Joined:
    Dec 1, 2002
    Posts:
    1,553
    Likes Received:
    0
    Location:
    WV
    got back from the garage today...they put it on a lift...ujoins are fine...and they think its the hub thats broke and not releasing

    going to swap in manual's anyway, so its no big thing
     

Share This Page