Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Draglink Problem

Discussion in 'The Garage' started by cdh, Jul 15, 2004.

  1. cdh

    cdh Registered Member

    Joined:
    May 6, 2002
    Posts:
    69
    Likes Received:
    0
    Location:
    Gilbert, Arizona
    I installed a new draglink a couple of months ago, and it has started to make a cracking or snapping noise when I turn the wheel (mostly when I turn to the left). With the wheels on the ground if I pull back and forth on the draglink I can reproduce the sound. Should I replace the draglink, reinstall, let it be, etc?

    Thanks
     
  2. bigyellowjimmy

    bigyellowjimmy 1/2 ton status

    Joined:
    Jan 15, 2004
    Posts:
    2,105
    Likes Received:
    0
    Location:
    Chandler, AZ
    Shouldnt make a noise, I'd say remove whatever is making the noise and replace. Are you sure you greased it well?
     
  3. cdh

    cdh Registered Member

    Joined:
    May 6, 2002
    Posts:
    69
    Likes Received:
    0
    Location:
    Gilbert, Arizona
    It worked well for a couple of months and started to make noise. I have greased it a couple of times since installation. Good thing I bought NAPA lifetime parts. I have had nothing but problems with NAPA parts for the last couple of years, and the draglink was my last purchase!
     
  4. bigyellowjimmy

    bigyellowjimmy 1/2 ton status

    Joined:
    Jan 15, 2004
    Posts:
    2,105
    Likes Received:
    0
    Location:
    Chandler, AZ
    Ive got a used drag link you are welcome to try just to make sure the noise goes away /forums/images/graemlins/thumb.gif

    BTW- why did you replace the drag link in the first place, same noise or another problem?
     
  5. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    Is anything visibly loose in the draglink. Could the hole in the steering arms (axle or steering box arm) be egged out? Also you may want to check the frame by the steering box as those are notorious for cracking and causing the noises you describe (pulling on the draglink would simulate steering and causing it to pop as well). Just some alternate (related) things to investigate if the parts are as new as you say.
     

Share This Page