Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

draglink problems

Discussion in 'The Garage' started by Jonny-K5, Jul 13, 2003.

  1. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    i put a 3" lift on a month ago. i used a 2" drop pitman arm. adjusted drag link all the way tight to center steering wheel. two weeks ago i start hearing a binding sound when i'd turn the wheels going slow (under 5 mph)
    like if im pulling in or out of a parking spot. its gotten progressivly worse and i think ive pinpointed it to the bolt that connects the steering arm to the drag link. how can i fix this? i tried greasing already. should i disassemble and lube the bolt? also the pitman arm that i got from ORD seems to have a bad angle thru its travel. would a raised steering arm have been better to keep the draglink closer to stock movement?
     
  2. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    hard to pinpoint where your problem may lie

    you say the rod ends are greased?
    when you say a tube that connects to drag link I assume you mean the draglink(as it is a tube consisting of 2 rod ends and an adjuster sleeve in a stock chev) between the steering arm and pitman arm

    binding sound?
    do you have anyone that can turn the wheel lock to lock while you watch the steering?
    it could be the frame is cracked under the steering box.
    until you get to watch it you will not know what it is.

    I cannot think of any bolts that would require lube or that will be loose enough to make a sound.
     
  3. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    the clicking /binding sound is coming from the end of the draglink that connects to the steering arm. i have gotten under the truck while a buddy turned the wheel, thats how i figured out it was the draglink end. i can feel/hear it clicking . just to be sure i used 3 dollar auto stethascope and am sure its the end. i can't figure out why its making this sound. each time i drive it the sound gets louder and happens more often. doesnt make sense to me. /forums/images/graemlins/1zhelp.gif
     
  4. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    Then just replace that drag-link joint at the pitman arm...They are pretty cheap...I think it is like 25-30 for a Moog Drag link end...

    Chris
     
  5. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    thanks, i figured that would be the answer.
     

Share This Page