Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

DRIVELINE NOISE!!! Need Help ASAP!!

Discussion in 'The Garage' started by BXwildshot, Dec 1, 2003.

  1. BXwildshot

    BXwildshot Registered Member

    Joined:
    Sep 17, 2001
    Posts:
    97
    Likes Received:
    0
    Location:
    Bronx , NY
    I have an 89 Suburban with the original 10 bolts awaiting a 14 bolt/D60 transplant. Yesterday I was cruising down the street when I noticed the truck was making a clanging/knocking sound which to me was coming from the pass. side front. The sound would change pitch and get louder when I hit the brakes. Anyway I got it home and proceeded to take off both pass. side tires to check the brakes , NOTHING. Took the pass AUTO hub off, NOTHING. Took driveshaft off to check u-joint and CV, NOTHING. Finally took off rear diff. cover to see if I lost a tooth somewhere but once again, NOTHING. The rear is I believe a GOV-LOCK or whtever was stock posi in 89 but I don't see anything obviously wrong with it thru' visual inspection. The only other things I can figure is that its coming from the drivers side drum brake or the transfer case BUT the noise DOESN'T occur when in REVERSE or if the rear tires are OFF the ground. Sorry about all the reading but I wanted to explain this well. Anybody have any ideas?

    Thanks
    Eric
     
  2. BXwildshot

    BXwildshot Registered Member

    Joined:
    Sep 17, 2001
    Posts:
    97
    Likes Received:
    0
    Location:
    Bronx , NY
  3. justhorsinaround

    justhorsinaround 3/4 ton status

    Joined:
    Sep 16, 2003
    Posts:
    6,798
    Likes Received:
    0
    Location:
    Northerish Phoenix, Az
    I would look at the rear drum like you said. Maybe a spring busted up in there. The other one would maybe be you have a warped rotor. That would make those kinda noises as well. Maybe some one else can come up with some better ideas. Good luck to ya.

    Allan
     
  4. justhorsinaround

    justhorsinaround 3/4 ton status

    Joined:
    Sep 16, 2003
    Posts:
    6,798
    Likes Received:
    0
    Location:
    Northerish Phoenix, Az
    Dangit, where was my head. Is that thing IFS?? If so check your half shafts. That's a better thought cuz on account I had an 89 Z-71 that made those same noises and it was a worn out half shaft. Again, good luck to ya.

    Allan
     
  5. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    89 suburban is still solid axle...

    anyways...did you check for tightness of the front wheel bearings? if they are loose and allowing the rotor and hub assy to walk on the spindle..possible loose caliper, or broken caliper bolt, maybe broken pad? did you make sure that the rear shoes havent seperated ie: the lining from the backing plate?
     
  6. BXwildshot

    BXwildshot Registered Member

    Joined:
    Sep 17, 2001
    Posts:
    97
    Likes Received:
    0
    Location:
    Bronx , NY
    Thanks for the replies guys but I think I found it. I think it the rear outside axle bearing that crapped out.Eric
     

Share This Page