Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

ecm mishap Any help appreciated!!!

Discussion in 'The Garage' started by jimmystyles, Oct 24, 2005.

  1. jimmystyles

    jimmystyles Newbie

    Joined:
    Oct 24, 2005
    Posts:
    4
    Likes Received:
    0
    Location:
    winter park, fl
    I have a very clean 89 k5 and this weekend. It just shutoff and won't run. Checked fuses, and the ecm fuse blows every time you turn the ignition forward. It cranks over but won't fire and can't hear the fuel pump running. Looked for a broken or burnt wire everywhere. Anyone ever heard of this. I'm not the greatest with electrical. Please help!!!
     
  2. 89GMCSuburban

    89GMCSuburban 1/2 ton status

    Joined:
    Nov 15, 2001
    Posts:
    3,005
    Likes Received:
    0
    Location:
    Thornton, CO
    You've got a short somewhere. Check around the motor for any wires that are melted.
     
  3. jimmystyles

    jimmystyles Newbie

    Joined:
    Oct 24, 2005
    Posts:
    4
    Likes Received:
    0
    Location:
    winter park, fl
    kinda thought so

    Thanks for the quick reply, I figured that's what's wrong but I didn't know if maybe one of the sensors going bad created a problem like this. I'll go on a mad hunt tomorrow.
     
  4. 89GMCSuburban

    89GMCSuburban 1/2 ton status

    Joined:
    Nov 15, 2001
    Posts:
    3,005
    Likes Received:
    0
    Location:
    Thornton, CO
    Nah, mine blew after a long trip and kept popping like yours is doing. The connector to the oil pressure sensor had melted and shorted out, blowing the ECM fuse.
     
  5. jimmystyles

    jimmystyles Newbie

    Joined:
    Oct 24, 2005
    Posts:
    4
    Likes Received:
    0
    Location:
    winter park, fl
    I couldn't wait till tomorrow, so I went outside and did some flashlight fishing. Appearently the idiot that charged my A/C, took the air cleaner off and pinched one of the injector wires. It started right up like usual. Thanks for the guidance.
     
  6. 89GMCSuburban

    89GMCSuburban 1/2 ton status

    Joined:
    Nov 15, 2001
    Posts:
    3,005
    Likes Received:
    0
    Location:
    Thornton, CO
    Sweeet, good find! :waytogo:
     

Share This Page