Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

ECMB fuse keeps blowing

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by badfish4tail, Apr 23, 2005.

  1. badfish4tail

    badfish4tail 1/2 ton status

    Joined:
    Mar 1, 2005
    Posts:
    1,684
    Likes Received:
    1
    Location:
    Long Beach
    this is related to my other thread "help, fuel pump" i got my truck running this morning for about 20min and now the "ECMB" fuse keeps blowing. I know its for a computer, but wich one? and does this mean my computer is bad or does it mean something else....
     
  2. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    There are a few things on that fuse, cant recall off hand what they are, a quick search should net you the answer, but the main thing is the fuel pump is on that fuse.
     
  3. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    I think its the fuel pump, fuel pump relay and oil pressure switch
     
  4. nerraw117

    nerraw117 1/2 ton status

    Joined:
    Jan 5, 2005
    Posts:
    788
    Likes Received:
    0
    Location:
    charlotte, NC
    o wow k20 knows all about this...i had the same problem, and it sucks, i replaced my fuel pump, sending unit and all that who ha. my problem that i found was a short on the wire going to the IAC, i THINK that fixed my problem i am not a 100% sure. check all your wires.
     

Share This Page