Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Edelbrock intake problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Chris1972, Dec 30, 2000.

  1. Chris1972

    Chris1972 Registered Member

    Joined:
    Nov 21, 2000
    Posts:
    22
    Likes Received:
    0
    I have just installed a new engine in my truck. Its a rebuilt 400cid. i had planned to use all the extras from my old 305 but there is a hole in the edelbrock preformer intake witch i have nothing to block with or use for. Its just in front of the themostat to the right when standing in front of the car.
    Can someone please help me.



    see my Blazer 2 at
    http://www.broadpark.no/~csteinsv/
     
  2. CrazeeBush

    CrazeeBush 1/2 ton status

    Joined:
    Apr 17, 2000
    Posts:
    464
    Likes Received:
    0
    Location:
    Middle Tennessee
    If it's just a water passage, just use a pipe plug in it. Preferably brass b/c it's a soft metal. I just installed mine and had to plug it.. I think it's either 3/8" or 1/2" thread.


    -JoSH
    crazeebush@aol.com
    <A target="_blank" HREF=http://josh.coloradok5.com>http://josh.coloradok5.com</A>
     
  3. K5-Kowboy

    K5-Kowboy Registered Member

    Joined:
    Aug 31, 2000
    Posts:
    35
    Likes Received:
    0
    Location:
    Virginia
    I did the same thing with mine...used a brass pipe plug. Haven't had any problems with it.

    [​IMG]<font color=blue> K-5 Kowboy </font color=blue>[​IMG]

    Go Through It or Go Over It....Going around is NOT an option.
     

Share This Page