Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Edelbrock Tubular Exhaust System (TES) install question

Discussion in 'The Garage' started by opfor2, Mar 7, 2006.

  1. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    Hi group,

    4 my birthday my wife got me an Edelbrock Mdl#68573, Tubular Exhaust System (TES), for my 1990 Blazer w/350. My question for those of you that have this installed what problems did you run into when you did the install ?

    The directions seem pretty straight forward and I would like to get an idea as to what I have to look forward too. I hope I can get this installed in a day for my truck is my DD.

    Thanks

    Dan..
     
  2. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    Wow, that's good info to have about changing the plugs. Did you notice any change in power or gas mileage? The only reason I got three is because my OEM left manifold has cracked and LMC wanted almost $ 400.00 for just one replacement. What a bunch of BS. that's too much $$ for just one manifold.

    Thanks for the reply

    Dan..
     
  3. jekbrown

    jekbrown I am CK5 Premium Member GMOTM Winner Author

    Joined:
    May 19, 2001
    Posts:
    45,031
    Likes Received:
    366
    Location:
    Vancouver, WA, USA
    x2, except I just let the napa-bought paint bake in the sun on the driveway for a full 95 degree summer day. Worked for me.

    As far as mileage/power goes, no real way for me to tell, lots of other stuff (gearing etc) got changed right about the same time. sorry!

    j
     

Share This Page