Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

electrical gremlins in 1990 jimmy

Discussion in 'The Garage' started by dodgedude99, Jan 11, 2006.

  1. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    ok my step sons POS Jimmy has some electrical issues.

    if he first starts the truck in the morning, the brake lights, turn signals, and back up lights all work. after it has run 5 minutes they stop working.

    it almost seems like once the truck warms up, the lights **** up with it.

    if he just applies the brakes, just the brake lights come on.
    if he puts the turn signal on and hit the brake, the tail lights and back up lights flash and alternate like a cop cars.
     
  2. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    Be sure that you don't have a single element bulb in a dual element socket and check the grounds at the reat taillight housings. The grounds will cause that for sure.
     
  3. dodgedude99

    dodgedude99 1/2 ton status

    Joined:
    Jul 12, 2003
    Posts:
    784
    Likes Received:
    0
    Location:
    burbia of illinois
    even though it is fine for like 10 minutes then starts to do it?
     
  4. zeroz400

    zeroz400 1/2 ton status

    Joined:
    May 30, 2004
    Posts:
    410
    Likes Received:
    0
    Location:
    Libertyville, IL
    I had a problem with my truck where it would be fine till i hit the brake, then it started getting funky. Just had to fix the ground behind the driver side tailight.
     

Share This Page