Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Electrical issue-1st Gen, need help!

Discussion in 'The Garage' started by Ressurection, Jun 16, 2005.

  1. Ressurection

    Ressurection 1/2 ton status

    Joined:
    May 9, 2000
    Posts:
    360
    Likes Received:
    0
    Location:
    Prairie du Sac, Wisconsin
    :confused: Plugged the plug into the back of the dash tonight and had very dim dash lights and courtesy lights, but NOTHING when I turned the key on. ??? I've been running with the plug disconnected from the dash, and a jumper in the contacts that light the courtesy lights, which by the way, also allows the key to start the truck. Could this be simply a bad ammeter or voltage regulator? Or is it something more complex?
    HELP!!! :(
     
  2. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,924
    Likes Received:
    334
    Location:
    Fort McMurray, Alberta
    Sounds like a ground issue to me...

    Try checking your grounds to make sure everything is happy. I forgot to hook up the ground wire on my 74 when I first got it, all my gauges worked properly, but when I turned the headlights on, I'd get interior lights turning on, dash lights only kinda on, and a signal light on solid, inside and out, lol
     
  3. Ressurection

    Ressurection 1/2 ton status

    Joined:
    May 9, 2000
    Posts:
    360
    Likes Received:
    0
    Location:
    Prairie du Sac, Wisconsin
    Are you talking the main ground from the battery cable? Or where?
     
  4. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,924
    Likes Received:
    334
    Location:
    Fort McMurray, Alberta
    Not 100% sure about the 1st gens, but my 74 had a ground wire that ran from the harness that went up to the gauge cluster down to the parking brake bracket. I knew about the wire, I just forgot to hook it up when I put the truck back together.
     
  5. 3 on the tree

    3 on the tree 1/2 ton status

    Joined:
    Oct 16, 2004
    Posts:
    3,970
    Likes Received:
    0
    Location:
    gunnison colorado
    Haven't looked under the dash but, up front there are 3 grounds that I know of on my 70. Neg batt cable to engine block, ext volt reg to core support, pass inner fender to frame. I'm sure there are more, but that's what I saw cleaning the engine compartment.
     
  6. Roz

    Roz 1/2 ton status

    Joined:
    Mar 27, 2005
    Posts:
    900
    Likes Received:
    0
    Location:
    San Diego
    i would say grounding also, check the contacts on ure wires, and there should be one to the dash.
     

Share This Page