Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

electrical issue

Discussion in 'The Garage' started by cegusman, Aug 4, 2006.

  1. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    Have a problem with my right turn signal in the grill. It works fine when the lights are off, but when the lights are on only the side marker and tail light blink. The one in the grill just stays solid. What could cause this? I plan on trying a spare headlight switch when I get home.
     
  2. TheSunDanceKid

    TheSunDanceKid Registered Member

    Joined:
    Jul 22, 2006
    Posts:
    60
    Likes Received:
    0
    Location:
    arizona, gilbert
    well have you messed with any wiring at all or done some good ramping that could of knocked something loose if not then its probably the switch or relay
    sounds like you tryed to wire something because usally when you have the keys out of the ign and turn the blinkers on nothing happends intill you turn it to the run position
     
  3. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    wireharness is a brand new custon one. Yes with the keys off I get nothing like it should, I was saying when I turned my lights on is when the turn signal would quit working. Blinker relay is brand new too, it works fine, just not went the lights are on.
     
  4. hack500

    hack500 1/2 ton status

    Joined:
    Sep 16, 2005
    Posts:
    523
    Likes Received:
    0
    Location:
    Templeton, Ma
    are all the grounds, good?
     
  5. goldwing2000

    goldwing2000 Guest

    Yep. Bad socket ground, I'd say. With the lights off, it grounds through the other filament but when you send power to both, it just stays lit.
     
  6. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    Grounds should be good but I will check them.
     
  7. goldwing2000

    goldwing2000 Guest

    Could be a bad socket, too. There's no other reason for one light to work wrong while the rest are working right.
     
  8. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    Its a brand new socket too, but I will check it too.
     
  9. goldwing2000

    goldwing2000 Guest

    Might have some crossed wires in that brand new "custon" harness.
     

Share This Page