Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Electrical problems?

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by djl87, Feb 3, 2004.

  1. djl87

    djl87 Newbie

    Jan 9, 2004
    Likes Received:
    we got a 72 chevy pickup, lwb, 350, auto, 2wd and its having electrical problems....the battery is always dead (after recharging....new battery too) some times the blinkers work, sometimes they go really fast or really slow (they dont return now anyway...have new parts for it)...cd player cuts out sometimes and just switches on and off really fast and you cant turn it off.....and also sometimes when u go from park to D radio will cut out at the same time....to get the truck to start you have to jam the shifter way up past park.........any ideas whats going on...maybe a short????? theres a new altenator in there too....
  2. BobK

    BobK 1/2 ton status

    Oct 5, 2000
    Likes Received:
    Petrolia,Ontario,Canada but working in Port Huron,
    GROUND problem....definitely.My radio would cut out(on and off) before I checked my grounds.
    My ground cables were crud and in very poor condition.I replaced them all and no problems since.

    Battery to eng. block.
    Eng. block to frame.
    Body to frame.
    Wheel wells to frame.
    Instrument cluster to body.

    The more grounds the better in my opinion.
    I've grounded my Eng to frame and body to frame on both frame rails.

    Good luck
  3. Burt4x4

    Burt4x4 3/4 ton status

    Feb 17, 2000
    Likes Received:
    California (Modesto area)
    Yup I agreee, I had to clean up my headlight grounds cuz the radio playing would make them dim to the beat of the radio /forums/images/graemlins/confused.gif

Share This Page