Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine bogs????

Discussion in 'The Garage' started by johnathan, Feb 11, 2006.

  1. johnathan

    johnathan 1/2 ton status

    Joined:
    Sep 26, 2005
    Posts:
    376
    Likes Received:
    0
    Location:
    Ocean Springs,MS
    I had replaced my tired old 305 about 5 yrs ago with a remaned 350 still runnin strong but I have one problem I have yet to solve.Happens more in cold weather,but not a very consistant thing.Youknow might happen today then not again for a few days weeks.The engine will be runnin fine then I get this pulsating bogdown aaaaaoooooooaaaaaaoooooo,and I might pull off and the engie falls flat on face then pick up and fall right back down.I have been through two q-jets now I'm runnin a 1406 ps edelbrock.I have also replaced fuel pump,and of course plugs wires,cap,coil,module.I remember reading somewhere that the ecs could be to blame, and the remedy was to jump the a&c wires going to the dist.I'm noy really sure what they meant by jump the wires,not to good with wiring.Oh yeah it's an 84 k5. Any help would be GREATLY appreciated.
     
  2. theperfectgarage

    theperfectgarage 1/2 ton status

    Joined:
    Oct 5, 2005
    Posts:
    988
    Likes Received:
    0
    Location:
    tucson arizona
    Good question

    If I keep answering just your posts this a.m., people will start to talk:D .
    But this is a good question. The fact that it's an intermitent prob. leads me to believe it's maybe some junk getting in your needle and seat or possibly an intermitent elec. prob. I like the edelbrock for the money but I do think there really sensitive to dirt in the float bowl.
    Check your advance weights and springs in your cap also, once I had a really wierd running 350 and the weights and springs were all screwy. Fixed it with a cheapo kit from autozone. I've not heard of the wire jumping trick you mentioned. I also run earlier style HEI's with no ecm control.
     
  3. johnathan

    johnathan 1/2 ton status

    Joined:
    Sep 26, 2005
    Posts:
    376
    Likes Received:
    0
    Location:
    Ocean Springs,MS
    i'll try the springs and weights thanks.yeah i have a lotta questions built up,I just now got back on the net after about 6 mths.
     
  4. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,583
    Likes Received:
    945
    Location:
    Massachussetts
    The pick up coil in the HEI,or the module could cause theese symptoms too..seems like it would be hard for 3 carbs to all do the exact same thing..if its fuel related,I'd guess fuel pump, or a clogged "sock" in the gas tank might be starving it for gas momentarily..
     

Share This Page