Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine Gallop Prob. HELP QUICK

Discussion in 'The Garage' started by blackblazer717, Apr 26, 2005.

  1. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    first off its an 88 k-5 with TBI 350/700

    this has been happening for the past few mo's but only on a random basis.

    today on my way home from work it started to gallop at low RPM from 1500 and under, wont go away. (i used to be able to get it to go away if i cleared it out bu racing the engine) it gallops for a few second than dies
    it sounds like its running on 7 CYL. but i dont know
    - running rich when gallop hence the black smoke out the pipes
    - engine light is on now
    - will not go away
    - wont revv past 3500 it starts breaking up. any help would be AWESOME
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Pull the codes, use a paperclip, post them. Should find the instructions in posts here with search.
     
  3. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    thanks, oh and i took the plugs out and all of them are fouled

    LUKE
     

Share This Page