Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine has loud backfire sound that escalates with acceleration. HELP!~

Discussion in '1983-2005 S-Series models' started by mr_fujisawa, Nov 23, 2003.

  1. mr_fujisawa

    mr_fujisawa 1/2 ton status

    Joined:
    Sep 1, 2003
    Posts:
    288
    Likes Received:
    0
    Location:
    SF CA
    hey. i hope somebody can help me out with some advice because tomorrow morning i have to decide whether to junk it or try and fix it. btw it is an '88 s-10 with an auto and a rebuilt motor. i am unsure of the mileage on the new motor (*fuel injected), 2wd, but 233k on the body.
    here's the problem:
    i was driving down the highway this morning and all of the sudden i start to get these backfire sounding noises coming from under the hood. sort of intermintently. so i pull off the highway and into the nearest gas station. i turn the truck off and check the fluids. add alittle oil cause it was low and fire it back up. the firing is louder than before and whenever i give it even a little gas it is really loud (pop, pop, pop, pop) and the poping gets faster with more acceleration. what;s going on? should i try to replace the cap, plugs, and wires? will that even help? mebbe they are fouled out. or is the timing maybe off a little? HELP!
    a little background. the lifters are already dying. they have been making noise for a few weeks now. maybe it is related to that? what should i do? junk the truck or get it looked at. i feel like it is starting to nickle and dime me. but at the same time, another 7 months out of it would be acceptable for a couple $$$.
    sean
     
  2. 4x4Freak

    4x4Freak 1/2 ton status

    Joined:
    Apr 21, 2002
    Posts:
    792
    Likes Received:
    0
    Location:
    Lubbock, TX
    Check to see if the distributor hold-down is tight. It sounds like it might have turned and is throwing the timing off.
     
  3. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    valve train messing up somewhere, or a bad misfire ignition system, or raw fuel making it to exhaust pipe and exploding in pipes- in which was why my 83 was backfiring extremely loud and expanding the pipes and muffler every time it did it.
    rebuilt the carb and that fixed it totally completely.
     
  4. mr_fujisawa

    mr_fujisawa 1/2 ton status

    Joined:
    Sep 1, 2003
    Posts:
    288
    Likes Received:
    0
    Location:
    SF CA
    well it appears that i probably have some flattened cam lobes. hooray!
    so now i just need to decide whether to junk it, or dive in!
    /forums/images/graemlins/tongue.gif
     

Share This Page