Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine is missing... Help!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Blazin Ed, Aug 3, 2003.

  1. Blazin Ed

    Blazin Ed Registered Member

    Joined:
    Mar 29, 2002
    Posts:
    92
    Likes Received:
    0
    Location:
    Seattle
    It sounds like the K5 is running on 6 or 7 cyliners... When you put it in drive it almost dies. Could you guys let me know what things I can check on? It has new plugs, wires, cap, rotor, and fresh gas. Someone suggested the injectors might be plugged... It's an '88 with TBI.

    Any suggestions would be appreciated...!!!
     
  2. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,063
    Likes Received:
    71
    Location:
    Pleasanton, CA.
    So, where did it go? /forums/images/graemlins/grin.gif Seriously though, recheck your firing order if you just changed wires. Most of the time it is as simple as that, especially if it ran better before you started the tune-up.
     
  3. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    being tbi, i believe it only has 2 injectors, right? im probably wrong, but run a couple bottles of injector cleaner through the tank if its not your firing order, to clean the injectors, yes that stuff really works,..
     

Share This Page