Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine problems

Discussion in 'The Garage' started by bender725, Apr 4, 2004.

  1. bender725

    bender725 Newbie

    Joined:
    Dec 18, 2003
    Posts:
    1
    Likes Received:
    0
    Location:
    washington
    Im having some problems with my truck, 86 k5 350 700r qjet 4" lift 35's. i was wheeling yesterday and got hung up on a bank and couldnt turn my wheels because i had no traction to back up so i started rocking it until i got loose. when i got to the bottom of the hill i needed to back up and when i went to give it gas it bogged down, then when i went forward same problem if i get on the throttle it bogges down and has no power. if it is in neytral with no load on the motor it will rev up fine but seems to peak around 4000, seems to not be getting fuel, now today it will still rev up in neutral but as soon as its in gear it stalls out and wont go, any help would be greatly appreciated, thanks
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    First of all, welcome to CK5. /forums/images/graemlins/waytogo.gif Secondly please fill out your profile so we know where you're at.

    Have you done any troubleshooting to determine if it's a fuel or spark related issue? That's your first step- check for both fuel and spark.

    If it's a fuel problem, you may want to try swapping out your fuel filter to start with. If you seem to be getting lots of fuel, it may be an ignition issue. Check your timing.

    There are lots of things that could be happening, but we need a little more info, brother.
     
  3. NITRO

    NITRO 1/2 ton status

    Joined:
    Jan 9, 2002
    Posts:
    1,057
    Likes Received:
    0
    Location:
    Frankfort In
    I had a similar problem before. Sounds to me like ur carb went to hell. My quadrajunk did the same basic thing.it wouldnt run down low, but about 4000 and up it woulda do enough to get u going. I replaced it with an edelbrock and havent had a problem since.

    NITRO
     
  4. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    It seems hat the Q-jets are better carbs, but my Edelbrock carb fixed all the carb related problems on my blazer when I bought it... /forums/images/graemlins/peace.gif
     

Share This Page