Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine Restore

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BlazerGuy, May 24, 2000.

  1. BlazerGuy

    BlazerGuy 3/4 ton status

    Joined:
    Apr 20, 2000
    Posts:
    9,206
    Likes Received:
    0
    Location:
    abcde
    Anyone ever use that engine restore stuff, is it any good, can you notice any difference? Also what kind of fuel additives do you guys use?

    <font color=green>Money</font color=green>--&gt;Blazer
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    I've used Restore brand oil additive in both my trucks, and have noticed an increase in oil pressure. I can't say if my performance or mileage was better, but it sure made me feel good to look at that pressure gauge and see her running high. Other guys who have used the same product have noticed similar results.....
     
  3. **b**

    **b** 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    279
    Likes Received:
    0
    Location:
    KIllington, VT.
    I dont think it sounds like a good idea...
    too good to be true...

    just my .02 cents
     
  4. Eric78K5

    Eric78K5 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    230
    Likes Received:
    0
    Location:
    South Carolina
    I've used it. I haven't noticed any performance improvements, but my oil pressure also increased. This could be because the stuff is like thick or heavy oil though.
     
  5. Thumper

    Thumper 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,582
    Likes Received:
    0
    Location:
    Alberta Canada
    I had a truck with a tired old 350 that would burn blue when i started it. The valve seals were shot, and the oil pressure just wasnt what it used to be. A can of the Restore stuff stopped the puff of blue at startup, and brought the pressure up enough to sell it. Keep in mind that its only a temporary fix.

    Mike


    <font color=blue>Thumper
    85 Fullsize Jimmy
    [​IMG]
    <font color=red>Lets Go Wheelin! </font color=red>
     

Share This Page