Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine runnig crapy

Discussion in 'The Garage' started by chebywanna, Oct 11, 2003.

  1. chebywanna

    chebywanna 1/2 ton status

    Joined:
    Apr 20, 2003
    Posts:
    277
    Likes Received:
    0
    Location:
    streamwood, (chicago)
    this is a none truck question but still motor problem
    vehicle- 87 riviera, one of them first distriubutor less fuel injected vehicles

    problem- runs rough when cold, fine when getting to operating temp, starts dieing out (but doesn't stall) for one sec, runs fine for five or so and dies out again, and back to normal at normal temp. on low throttle it seems to missfire constatnly and shakes a lot (as if it was loading up) but once over 2200? rpm its perfectly fine.

    history- the motor is a "new" one, or reather moved from another, unknown milage, and its been that way day one (all though sat for a year) spark plug wires were just replaced, and ran a bottle of fuel injector cleaner throught the system.

    any ideas?
    thanks

    jim
     
  2. blaz72

    blaz72 Registered Member

    Joined:
    Oct 7, 2003
    Posts:
    28
    Likes Received:
    0
    Location:
    connecticut
    Might be bad coolant temp sensour.
     
  3. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    possible, TPS, CTS, O2 sensor...etc
     

Share This Page