Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine running funny

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by damn90blazer, Sep 19, 2002.

  1. damn90blazer

    damn90blazer Newbie

    Joined:
    Aug 29, 2002
    Posts:
    2
    Likes Received:
    0
    i have a 90 350 TBI. the engine seems to idle real rough. gets to running temp real quick. and seems to not have any
    power after the initial off idle acceleration. its getting like 9 miles to the gallon on the highway and when i hit the gas
    it emits a horrible odor and when i let off the smell changes but its even worse. ive changed the distributor, coil, plugs
    and wires. have MSD dist and coil and bosch +4s ive also changed the throttle position sensor, map sensor and
    the knock sensor. i think the truck may be running too far advanced. any ideas? my next step is to replace the
    ECM and the ESC module.
     
  2. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    bad smell could be a clogged catalytic converter
    would also cause all the other symptoms
     
  3. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Also the IAC sensor is probably bad. That would explain the bad idle, and they seem to not work too well after all these years and miles. Its on the side of the TBI, cost aobut $35
     
  4. fr8train

    fr8train 1/2 ton status

    Joined:
    Aug 2, 2000
    Posts:
    1,712
    Likes Received:
    0
    Location:
    Maryland
    Have you changed the O2 sensor? If its a nasty egg fart smell your cat. conv. needs to be replaced.
     
  5. TIGHTWORK82 K5

    TIGHTWORK82 K5 1/2 ton status

    Joined:
    Oct 21, 2001
    Posts:
    140
    Likes Received:
    0
    Location:
    orlando , florida
    what about a bad head gasket ;burnin anti freeze smells pretty bad. try compression check.
     

Share This Page