Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine stumbles at highway speeds

Discussion in 'The Garage' started by cj7jeep81, Aug 16, 2004.

  1. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    My truck ('79 K20) has started stumbling at highway speeds (55-60 mph). It drives fine up until that point, but at that speed, it starts acting like its running out of gas (stumbles to the point of almost dieing, and the more I push on the accelerator the more it does it). It just started doing this in the last month or so. If I lay off and let it slow down, its fine. Also, if I really get on the gas from a dead stop, it runs just fine.
    Could the fuel pump be going out and causing it to starve only at the high end? Or could it be something else? I'm getting ready to sell this truck, and want to get all the little bugs worked out.

    Thanks for any help!
     
  2. ramjet gmc

    ramjet gmc CK5 Staff Staff Member Moderator GMOTM Winner

    Joined:
    Dec 19, 2001
    Posts:
    3,370
    Likes Received:
    0
    Location:
    Milltown NJ 08850 NJ sucks
    Could the fuel pump or fuel filter -my gess but ther are some much better moter people then me on ck5 /forums/images/graemlins/dunno.gif
     
  3. NITRO

    NITRO 1/2 ton status

    Joined:
    Jan 9, 2002
    Posts:
    1,057
    Likes Received:
    0
    Location:
    Frankfort In
    hey, where in Inidiana are you located? there's a couple of ppl around the state here that may live close and may be able to help you.

    NITRO
     
  4. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    I live in southeastern Indiana, about halfway between Cincy and Indy (small town named Osgood).
     
  5. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    Any one else have any ideas? Or does anyone know how to test the fuel pump to see if its bad?
     
  6. 88Silverado

    88Silverado 1/2 ton status

    Joined:
    Mar 13, 2003
    Posts:
    2,664
    Likes Received:
    0
    Location:
    Quartz Hill, So. Cal
    Change the fuel filter then see how it runs.
     
  7. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    If you figure it out, let me know as I'm having the same issues. I tried filters and new pump (even switched from mech. to elec.) and those did not work. If I figure it out, I will let you know.
     
  8. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    I'll try replacing the fuel filter, and see if that helps.
     
  9. camarossguy2

    camarossguy2 1/2 ton status

    Joined:
    Aug 10, 2004
    Posts:
    214
    Likes Received:
    0
    Location:
    ABQ NM
    [ QUOTE ]
    I'll try replacing the fuel filter, and see if that helps.

    [/ QUOTE ]

    Mine does the same thing. plugs show detonation. check your plugs, next fill up try some 93 and see if it does it. helped mine, although just a tempoary fix, these engines are not supose to have to have 93, im assuming i have another problem other then fuel oump and fliter, witch i have replaced.
    dunno
     
  10. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    Hopefully that's not it, it costs enough to fill it up as it is, but I'll check the plugs.
     
  11. SHAWNSTER

    SHAWNSTER 1/2 ton status

    Joined:
    Sep 24, 2002
    Posts:
    211
    Likes Received:
    0
    Location:
    DALLAS,TX
    when my 80 was doing this-i tried all the above and in the end it was a bad msd coil-u could drive the hell out of it till about 55mph and it jerked and acted like was out of gas-then changed coils and never had another prob
     
  12. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    That sounds like the exact same thing mine's doing. I'll look into that as well. Thanks for all the help everyone!

    [ QUOTE ]
    when my 80 was doing this-i tried all the above and in the end it was a bad msd coil-u could drive the hell out of it till about 55mph and it jerked and acted like was out of gas-then changed coils and never had another prob

    [/ QUOTE ]
     
  13. snotrocket14

    snotrocket14 Newbie

    Joined:
    Aug 1, 2004
    Posts:
    1
    Likes Received:
    0
    Location:
    Phoenix, Az.
    I had the same problem once. Check the fuel hose going into the fuel pump, especially where there might be a bend. If the hose is partially kinked or just old, It could collapse under higher RPMs. When you stop for a short period of time the carb will fill up with fuel and it will run fine when you put the hammer down. Worth checking out.
     
  14. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    [ QUOTE ]
    when my 80 was doing this-i tried all the above and in the end it was a bad msd coil-u could drive the hell out of it till about 55mph and it jerked and acted like was out of gas-then changed coils and never had another prob

    [/ QUOTE ]

    I'll see if I can find a spare to check mine. Do you know if yours only did it under load or all the time. The reason I ask is I can rev the snot out of it while in nuetral and it is fine (not RPM dependent).
     
  15. Bross82

    Bross82 1/2 ton status

    Joined:
    Feb 11, 2002
    Posts:
    215
    Likes Received:
    0
    Location:
    Spencer, MA
    mine does something similar. are you talking when you get up to highway speeds, if i try to step on the gas there is no power at all, but the weird thing is, if i step on the gas but hold it down. the exhaust goes from how it normally sounds (loud and everything), to just a dead bass noise, and it'll kinda buck. but, if i let off of the gas wheneever it does this and let it coast down a little, it starts running perfectly fine again. also, this doesnt seem to be a problem for some odd reason going up any inclines. it only happens going down-hill or on flat ground. really weird.

    could it be something with the air-fuel ration? i've added a 6" air filter with the xtreme flow top, and changed the 2 1/4" exhaust to 2 1/2". nothing has been done to adjust the 4 barrel edelbrock carb since doing this. would i need to adjust it besides the fact of this problem because of these upgrades? (since the air intake and exhaust should now be increased)
    thanks,
    matt
     
  16. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    What type of Edelbrock carb. I have the Edelbrock Q-jet and sometimes the same issue. I can rev the snot out of it with no load, but if I mash it, the RPM's will come up and at certain point it will cut out. It seems to do it going up hills but it is definitely different (maybe a float/jet issue).
     
  17. Bross82

    Bross82 1/2 ton status

    Joined:
    Feb 11, 2002
    Posts:
    215
    Likes Received:
    0
    Location:
    Spencer, MA
    i'm actually not sure what model, it was on the truck when i got it. what do i look for on it to check the model?
     
  18. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    I was too busy to work on it this weekend, but took it for a short drive and this time it was worse. It used to only stumble at higher speeds (50-60 mph), but this time it did it at around 25 mph, and then completely died on me.
    It still idles just fine, and if its in park, I can rev it way high without any problems.
     
  19. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Fuel Pump.
     
  20. cj7jeep81

    cj7jeep81 1/2 ton status

    Joined:
    Feb 17, 2003
    Posts:
    110
    Likes Received:
    0
    Location:
    Indiana
    [ QUOTE ]
    Fuel Pump.

    [/ QUOTE ]
    That's what I'm leaning towards as well. I picked up a new one the other day, so hopefully I can install it this weekend.
    Thanks everyone for the help!
     

Share This Page