Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine/tranny trouble

Discussion in 'The Garage' started by 77scottsdale, Jan 4, 2007.

  1. 77scottsdale

    77scottsdale Registered Member

    Joined:
    Dec 17, 2006
    Posts:
    93
    Likes Received:
    0
    Location:
    georgia
    would a bad modulator valve cause the truck to go dead after about 5 seconds of being put in gear, or a vaccum leak.

    and another thing the truck starts to skip when put in to high loc and press the gas, but not in low loc
     
  2. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,553
    Likes Received:
    939
    Location:
    Massachussetts
    maybe..unlikely..

    A bad modulator will make a vacuum leak,but usually they suck tranny fluid into the motor when the diaphram fails,not air,and that will eventually make the tranny run low enough on fluid to afftect shifting,or harm it!..

    A vacuum leak else where might kill the motor at idle,if its a large leak,like a PCV valve hose that came off ,or the one to the power brake booster--the smaller hoses wont affect it that badly,though they may cause a rough idle or stumble on acceleration if they are leaky or dissconnected...

    You may have weak spark in some cylinders that causes the motor to skip under a load--its under more strain in "high" range than "Low" range,so that might be why it only misses in high range..weak spark will not fire under heavy loads,it blows out and doesn't fire the fuel air mixture..check the plug wires,plugs,and cap and rotor..I bet some are either damaged, or old and cracked,and let spark jump to ground, rather than fire the plugs...:crazy:
     
  3. 77scottsdale

    77scottsdale Registered Member

    Joined:
    Dec 17, 2006
    Posts:
    93
    Likes Received:
    0
    Location:
    georgia
    the wires are new morroso 8mm, but there solid supression core would that matter, i have a summit racing hei upgrade kit, and e3 plugs

    can a np203 go bad an not make any grinding noises
     

Share This Page