Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Engine Trouble (1980 k5)

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by pregate, Aug 13, 2000.

  1. pregate

    pregate Registered Member

    Joined:
    Aug 13, 2000
    Posts:
    83
    Likes Received:
    0
    Location:
    Fort Worth, Texas
    ok, i just bought this truck 2 days ago, and all seemed fine till tonight

    i was driving down a street, and i noticed it got to a point where it wouldnt go above a certain speed, i pumped the gas a little and it went back to normal.
    then i stopped at a light, and when i gassed it when the light turned green, i didnt move hardly at all. after pumping it a few times, i made it across the intersection and began to build speed.. this happened most of the way home, at least twice the truck died at a stoplight and i had to put it in park and restart it. now about a mile or two away from home, it stopped acting up, and was driving as normal. i took it home, talked to my dad and we drove it around a little, it seemed ok, and would build decent speed (we couldnt go tearing around residential areas)

    we have no idea whats going on, as neither of us are mechanics surely, im trying to learn as i go but i have no clue as to the problem. we talked to a friend of ours and he said its probably one of the two fuel filters.

    anyway, any ideas?

    (yes it has plenty of gas)
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Other than the fuel filters, there may be a problem with your accelerator pump in your carb. Are there signs of flooding, like a strong smell of gas? If so, it could be as simple as a choke adjustment, if it's sticking. But what you described is similar to what I experienced when the accelerator pump started crapping out on my Quadrajet, although normally when they're gone, they're gone!!!!

    You also could be lucky and it might just have been a little piece of crud that got lodged in your carb. If it got knocked/flushed out, everything should return to normal.

    Since you just bought the truck, it might be a good idea to replace all the filters(fuel, air, and tranny) and do an oil change anyway. You might save yourself another surprise sometime down the road.
     
  3. pregate

    pregate Registered Member

    Joined:
    Aug 13, 2000
    Posts:
    83
    Likes Received:
    0
    Location:
    Fort Worth, Texas
    yea, we were planning on taking it to the mechanic anyway, since we have a few hundred bucks left after buying it..

    -edit-
    ok, this is a really dumb question..
    its an automatic, so a full time 4WD..
    it should have 5 gears (low loc,low, neutral, hi, hi lock)
    it should be in High for normal driving
    we can only identify 4 of the gears
    Hi lock, the 4WD lock light comes on, so we can tell its that, we arent sure if were skipping over a gear between Hiloc and what seems to be neutral, the shifter doesnt seem to set in place, but we cant tell worth a damn

    blah.. im a moron

    anyway, hoping that its nothing major, and the truck being a stock k5 cheyenne, anyone have a recommendation on a few starter improvements for it? i plan on offroading after i learn a little more about it


    1979 K5 Blazer
    4x4, 350 V8
     
  4. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,180
    Likes Received:
    1,388
    Location:
    E-town baby!
    Hi there! <font color=red>First of all congrats on buying your K5</font color=red>
    Did the truck sit for an extended time before you bought it? If so your fuel system might be gummed up, crap in the tank ete. etc.. My friend bought a 4x4 van that sat for about 2 years without moving and had similar problems like what you were describing. He rebuilt the carb, same problems after driving for about an hour. He replaced the carb (new) and filters and again had the same problem after about two days of driving. He finally got medievel on it and replaced the tank (new), fuel lines and carb again [​IMG]. You can bet he was pretty pissed off at this point, but problem solved. You shoulda seen what was in that gas tank.
    If you want to find what range your T-case is in try driving alittle in each range, including neutral, that should tell you what is what.
    I would not jump into your first mod. wheel it stock with some other trucks and see what works and what appears to be a waste of money. Just my opinion. Do the research, check out the tech. articles on this site, magazines etc. that should give you some ideas.
    [​IMG] Sorry for the novel [​IMG]

    Rene <font color=red> 81 K-20 Jimmy </font color=red>
    <font color=green>[​IMG]"God hates a coward"</font color=green>[​IMG]
     
  5. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,180
    Likes Received:
    1,388
    Location:
    E-town baby!
    Is your truck a 1979 or an 80? Because if it is an 80 it should have the NP 205 part-time case not the NP 203 full time case.

    Rene <font color=red> 81 K-20 Jimmy </font color=red>
    <font color=green>[​IMG]"God hates a coward"</font color=green>[​IMG]
     
  6. pregate

    pregate Registered Member

    Joined:
    Aug 13, 2000
    Posts:
    83
    Likes Received:
    0
    Location:
    Fort Worth, Texas
    79

    i edited it cuz im a moron and forgot which year :)
    (i had been looking at a bunch of '80 vehicles so it kinda got stuck in my head)

    after fiddling with it for a while im pretty sure ive got it in the right gear

    and yea, it had pretty much been sitting for like the last 10 years, the guy hardly used to but to launch his boat at their lake house..

    1979 K5 Blazer
    4x4, 350 V8
     
  7. Eric78K5

    Eric78K5 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    230
    Likes Received:
    0
    Location:
    South Carolina
    Congrats on the purchase! Just as a side note, when I got my 78, it had been sitting for awhile. I changed all the fluid/filters right after I got it. I also added gass treatment, and oil treatment....hell, every treatment I could find...LOL. I don't like surprizes! You may want to try something like that also. Hope that helps.

    Eric78K5
    K5-Because Size Matters!
     

Share This Page