Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

engine trouble

Discussion in 'The Garage' started by BabeTheBigBlueOx, Apr 27, 2003.

  1. BabeTheBigBlueOx

    BabeTheBigBlueOx Registered Member

    Joined:
    Aug 31, 2002
    Posts:
    13
    Likes Received:
    0
    Location:
    Tennessee
    I'm having problems with my 305.It is over heating very quick and it is burning lots of oil.Please help.I'm in High school and i already own the biggest truck at school now I just need it to run right. /forums/images/graemlins/k5.gif jinxdresser@hotmail.com
     
  2. Okiemuddog

    Okiemuddog 1/2 ton status

    Joined:
    Mar 3, 2003
    Posts:
    1,260
    Likes Received:
    0
    Location:
    Guthrie, Oklahoma
    Are you getting smoke from the exhaust pipes? How many core radiator are you running. Do you have your fan shroud installed. When was the last time you replaced the thermostat and flushed the radiator? Is your engine leaking oil or burning it?

    Give me some more info and I might be able to help.
     
  3. MudNurI

    MudNurI 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,113
    Likes Received:
    0
    Location:
    VT
    definetly check the thermostat!

    and dont trust that it's been replaced either- even if you did it. When I replaced mine- the first one I bought was no good...wouldnt open...

    Are you burning oil - or leaking oil? There is a difference...check the valve covers- are they coated with oil? Check your sending units- are they leakings?

    and lastly- put some more information in your post- what year is this? how many miles etc....what have you checked

    Brandy
     

Share This Page