Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Finally turned orange, got a tranny question (no go with 700R4)

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by K5er4Life, Mar 5, 2003.

  1. K5er4Life

    K5er4Life 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    1,456
    Likes Received:
    0
    Location:
    Bellflower, Ca
    Finally got my membership! But on the bad side I did something to my 700R4, when I put it in gear nothing happens (basically like Im in neutral all the time). I was boggin thru some mud then on my way out of the canyon I noticed it took more gas to get the truck going, then it got so bad that within a matter of feet it nothing happened. I thought I boiled the fluid or something but then it sat for about 3 hours and I tried it again and nothing. How much am I lookin to get this thing fixed? or I would really like to throw in a 4L80 (I need OD for my many highway miles) how much trouble am I lookin to go that route? other than computer stuff with the tranny, I mean like will I have a prob with my NP208? Thanks guys it has been the longest day, wheelin my truck and blew up tranny, 200 dollar tow bill, I barely have any cash I go to school full time and work. Hey but there is absolutely nothing I would change about the day, I got stuck with 2 hot chicks I took wheelin, they loved being around me for a few hours with nobody around.
     
  2. Sample

    Sample 1/2 ton status

    Joined:
    Oct 15, 2002
    Posts:
    536
    Likes Received:
    0
    Location:
    Apache Junction, AZ
    That sounds just like the 700 i my K5. It acts like it is nuetral no matter what. I believe it is the tranny pump on mine, that is a couple hundred bucks just for the part, then you have to tear apart the tranny and replace pumo and seals. I am lucky, my father in law is GIVING me a TH400 and 208 out of his suburban.

    BTW, this thread is worthless without pics of the hot chicks. /forums/images/graemlins/wink.gif
     
  3. BigBluOx

    BigBluOx 1/2 ton status

    Joined:
    Aug 30, 2001
    Posts:
    301
    Likes Received:
    0
    Location:
    Auburn, WA, USA
    When this happened to me it was just the Torque convertor. I still took the tranny into a specialist to make sure no pieces found their way to the pump (fortunately none had). Pictures of the hot chicks? Bring 'em on!! /forums/images/graemlins/thumb.gif

    Jon /forums/images/graemlins/burb.gif
     
  4. K5er4Life

    K5er4Life 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    1,456
    Likes Received:
    0
    Location:
    Bellflower, Ca
    When I get home from work I'll post up some pics of the chicks and my rig.
     

Share This Page