Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Flaky speedometer

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by kilroy, May 10, 2002.

  1. kilroy

    kilroy Registered Member

    Joined:
    Nov 25, 2001
    Posts:
    85
    Likes Received:
    0
    Location:
    Alaska, Anchorage area
    If you have had this problem please tell me what you found and what you did it fix it. My speedo works about 90% of the time, but sometimes while driving it will quit, the needle will just drop to 0 or 25 or go up to the max peg, when it does this the odometer quits working no matter where the needle comes to rest. Then it will start working again, generally within a mile or so of when I notice the problem. Nothing else in the dash or any where else in the truck seems to be affected. I have only noticed this when I am going highway speeds (95% of my daily traveling). 90 GMC Jimmy with stock 350 TBI and auto trans
    Thanks
    Tramp
     
  2. Blazer_Boy

    Blazer_Boy 1/2 ton status

    Joined:
    Dec 16, 2000
    Posts:
    1,669
    Likes Received:
    0
    Location:
    Sioux City, IA, USA
    Probably electrical because I believe they switched to that style in '90. The trasnfer case should have the sender, try changing that. You may have a short or something. You loose the signal and it will falls, if it gets grounded and it pegs.
     

Share This Page