Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Flashing Parking Brake Warning Light

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by jc71355, Feb 28, 2003.

  1. jc71355

    jc71355 1/2 ton status

    Joined:
    Jan 13, 2002
    Posts:
    830
    Likes Received:
    0
    Location:
    Port Neches, Texas
    I've been having problems with my speedometer jumping, causing my truck to run poorly, tranny, brakes.... seems like all of it /forums/images/graemlins/frown.gif I've been trying to read in the service manual how to go solving these problems. I've talked to a tranny guy and a guy at the dealer ship and no one knows. I tested the ground like the manual says and got low voltages on that (.4 to .8). So I'm assuming that it is properly grounded. I cannot find the ground for it so I haven't been able to look at it to see if it is bad. The dealerships have told me that the DRAC has been discontinued and no one around me sells them. I've contacted a few companies but I haven't heard back from them yet.

    This problem has been going on for a little over a week now. I can go most of the day w/o any problems and then the speedo will just go bannana's and jump all over the place /forums/images/graemlins/confused.gif The only regularity in the whole mess is it seems to happen after I travel at highway speeds for a while and then slow down to the 50-55 mph range. A few days ago my parking warning light came on and wouldn't go off as long as the ign. was on. Today I did the voltage test and tried to find the ground and finnally gave up and pluged everything back in. When I turned the key back on the light began to flash. It will quickly flash 4 times and hold on the 5th. It flashes much faster than the check engine light. Can anyone help me with my situation? I have changed the VSS so I know it isn't that. No one seems to know a whole lot about these speedometer systems.

    Please Help before I loose it and shoot this thing,
    James /forums/images/graemlins/crazy.gif
     
  2. BRN78BLAZER

    BRN78BLAZER 1/2 ton status

    Joined:
    Feb 5, 2003
    Posts:
    133
    Likes Received:
    0
    Location:
    Stoney Creek Ontario, Canada
    Hmmm, definately sounds like a computer problem, if it's causing most of the systems to go haywire at once, when in fact I'm guessing that there is nothing really else wrong with the vehicle. My friends 90 berrata similiar symptoms which were cured simply by disconnecting the battery for a few seconds then hooking it back up. I geuss you could try that. If that yeilds nothing I would have someone with a scanner see what the computer is doing. All I can think of.
     

Share This Page