Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Float level question

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BRN78BLAZER, Jun 16, 2003.

  1. BRN78BLAZER

    BRN78BLAZER 1/2 ton status

    Joined:
    Feb 5, 2003
    Posts:
    133
    Likes Received:
    0
    Location:
    Stoney Creek Ontario, Canada
    If my float was improperly adjusted, could that give the symptom of the truck feeling like it wants to stall when I come to a stop? I know pump and filter are good, now I'm wondering if it could be the float level, to high or low or something?

    thanks for any replies
    Steve

    oh, its a 305 rochestor 2bbl.
     
  2. mud390

    mud390 1/2 ton status

    Joined:
    Oct 31, 2002
    Posts:
    1,210
    Likes Received:
    0
    Location:
    Little Rock, Arkansas
    My buddy's Nova had a smiliar problem. We found that his floats on his carb we set way to high. His car would load up and stumble when the car idled for to long or after he had his foot in it. Might be a good place to start. Good luck.

    Kris
     
  3. BRN78BLAZER

    BRN78BLAZER 1/2 ton status

    Joined:
    Feb 5, 2003
    Posts:
    133
    Likes Received:
    0
    Location:
    Stoney Creek Ontario, Canada
    Thanks, /forums/images/graemlins/thumb.gif
     
  4. wrathORC

    wrathORC 1/2 ton status

    Joined:
    Apr 27, 2002
    Posts:
    908
    Likes Received:
    0
    Location:
    Hancock, MI
    Yeah, and it could be a symptom of a "loaded" float. I recommend spending the $8 for a new float if you're going to pull it apart.
     
  5. FWP

    FWP CRS

    Joined:
    Oct 11, 2000
    Posts:
    3,845
    Likes Received:
    3
    Location:
    Prescott Valley, AZ
    What makes you lean towards the float, did you just work on something there, or??? Stall on de-accel makes me think of stuck open EGR, vacuum lines broke, things of that nature.....
     
  6. BRN78BLAZER

    BRN78BLAZER 1/2 ton status

    Joined:
    Feb 5, 2003
    Posts:
    133
    Likes Received:
    0
    Location:
    Stoney Creek Ontario, Canada
    Well, there's no egr, and all hoses are good. It's a rebuilt carb and it always had this problem. The only way to compensate was to run a very rich idle mixture, but that fouls up my plugs, and just wastes gas. So I leaned it out, but now it seems like it wants to stall on deaccel. My only guess is float level.

    Thanks so far guys /forums/images/graemlins/thumb.gif
     

Share This Page