Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Front Spring hanger problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by morphed86k10, Nov 24, 2002.

  1. morphed86k10

    morphed86k10 1/2 ton status

    Joined:
    Jun 25, 2001
    Posts:
    463
    Likes Received:
    0
    Location:
    Reno Nevada
    After breaking a front shackle and replacing it with ORD stuff I thought I was set. Until I hear a creaking coming when I steer. At first I thought it was the frame around the steering box, but its actually one of the brackets that holds the front spring hanger (on the driver side). It's cracked completely through, no wonder it was creaking! Anyone ever had this problem before, or come across a good way to fix it, i.e. aftermarket replacement brackets?
     
  2. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Yeah I had a problem with one. I cut one off a doaner truck and used grade 8 bolts to put it on my frame. I think the bolt size that fits the rivit holes properly is 7/16's or drill them out to 1/2 inch.
     
  3. CrazyCoot

    CrazyCoot Registered Member

    Joined:
    Nov 24, 2002
    Posts:
    25
    Likes Received:
    0
    Location:
    Redding, CA
    What Reaper said. And I usually weld them too at work. I wouder sometimes if the grade 8 bolts would be too hard and sheer off.
     

Share This Page