Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Fuel Delivery Problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 78GMC1/2TON4x4, Sep 1, 2003.

  1. 78GMC1/2TON4x4

    78GMC1/2TON4x4 1/2 ton status

    Mar 10, 2003
    Likes Received:
    Mount.Angel, OR
    I have been going through hell with my 78 K15. For some reason no fuel is getting to the pump and getting delivered to the carb. I just recently replaced the sleector valve for the tanks and i ran it for 5 miles at the most....she shut off and now no gas sucking at all...THE PUMP IS PUMPING THOUGH, we tested it but it sucks no gas from the tank any suggestions? /forums/images/graemlins/truck.gif
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Feb 17, 2000
    Likes Received:
    Cochrane, Alberta, Canada
    So if I understand this right your fuel pump is capable of pushing but not pulling? I'm not sure exactly how a mechanical pump works- is it a two stage pump(as in pull/push)?

    Why did you change your tank selector valve? Is there a chance that the new one is shot or that maybe it was installed incorrectly? And have you swapped in a new fuel pump just in case the problem lies there?

    I'm sure you've looked into this as well, but are you sure there's gas in the tanks? Just thought I'd ask.....

Share This Page