Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

fuel delivery question!

Discussion in 'The Garage' started by blackblazer717, Jul 1, 2004.

  1. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    ok
    i have an 88 K-5 with a 350 and TBI, last week the motor quit, i found that the PCM-B fuse had blown which is the fuel management fuse. i have replaced the pump relay and the in-tank fuel pump as well as the fuel filter (cause i was under their) and the problem persists. you can put a new fuse in and the truck will run until you take it down the road and than the fuse will pop again. any help would be greatly appriciated

    also, is it possible to bypass all of the factory harness and hard wire the pump to a switch? and have the truck runand not just have the pump come on?
    thanks
    luke
     
  2. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    YOu have a short somewhere...First, I would ensure you have a good ground at the fuel pump. Then start checking the wire from the FP to the FP relay. You can hardwire a 12v+ but I wouldn't reccommend it...Fix what you got /forums/images/graemlins/wink.gif

    Chris
     
  3. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    i also traced the tan/wht wire from the FP to the relay, though the bulkhead connector and to the fuel pump oil press switch and everything is checkin out.
    also i tryed hard wireing the fuel pump and it will turn on with the switch but the truck wont fire, maybe somthing from the ECM is required???
     

Share This Page