Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

fuel gauge/ low idle stall

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by MA87K5, May 27, 2000.

  1. MA87K5

    MA87K5 1/2 ton status

    Joined:
    Apr 6, 2000
    Posts:
    558
    Likes Received:
    0
    Location:
    Chicopee, Ma 01020
    Hey everyone. Well the first problem I have is that my fuel gauge moves while the K5 is standing still. What could cause this? I have tried fixing it by tinkering with the sending unit but no change. The second problem is that it will stall or get real close to stalling when the idle gets low or even while I am driving slow like around 5-20 mph. I have 87 K5, 350 TBI, 700r4. Please help. Thank you
     
  2. coopertwpk

    coopertwpk 1/2 ton status

    Joined:
    Mar 18, 2000
    Posts:
    478
    Likes Received:
    0
    Location:
    Spring Valley Lake Ca.
    idle contol solnoid (left side round with four plug connection)remove it and spray carb cleaner in the hole it may be plugged it should vibrate when you turn ont the key it controls air flow to keep the idle steady.
     
  3. dumbfounded

    dumbfounded 1/2 ton status

    Joined:
    May 20, 2000
    Posts:
    176
    Likes Received:
    0
    Location:
    Castalia, NC
    check your air cleaner and throw in some carb/efi cleaner in the gas (can't hurt its cheap), as for the gauge check connections. Does it do it with the key on and engine off?

    Blood, sweat, tears, and lots of money is what keeps my K5 alive.
     
  4. jarheadk5

    jarheadk5 1/2 ton status

    Joined:
    Mar 6, 2000
    Posts:
    4,389
    Likes Received:
    0
    Location:
    PA
    Replace the fuel filter as well. Inside the right framerail under the pass. door. 10 minute job.

    Silly question, but does the gauge move after stopping, or when the truck has been still for a while? I'm thinking the gauge may be dying, or the circuit may have a poor ground somewhere. Or, the baffles in the tank aren't doing their job.

    [​IMG] Semper Maintenance!
     
  5. MA87K5

    MA87K5 1/2 ton status

    Joined:
    Apr 6, 2000
    Posts:
    558
    Likes Received:
    0
    Location:
    Chicopee, Ma 01020
    The fuel filter is new about 4 weeks ago. The gauge moves when truck is still and moving also with the key on and engine off, but I worked on it on Saturday and so far it is fixed. I'll try to spray the silonoid with cleaner. Thanks
     
  6. Blazer79

    Blazer79 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,816
    Likes Received:
    0
    Location:
    Guatemala, Central America
    Mine did the same thing. I followed the wire that comes from the tank. I found it was broken and someone had just twisted up the two broken ends and were all dirty. Definitely a bad contact. I cut them off and redid the union. Problem solved.

    <font color=black>//////
    What the heck!...Drive it like gas is $0.50/gal!!!
    </font color=black>[​IMG]
     
  7. Whii338

    Whii338 Registered Member

    Joined:
    Apr 24, 2000
    Posts:
    35
    Likes Received:
    0
    Mine did the exact same thing...low speed stalling but ran ok at speed....88'K5 350 Tbi auto.. and the egr valve was bad...stuck, whatever ,no emissions inspection in alabama so its just unhooked and runs fine but i am going to replace it soon(it may make your check engine light come on..but mine was bad and didnt come on:) run great now...just my 2cents.
     
  8. MA87K5

    MA87K5 1/2 ton status

    Joined:
    Apr 6, 2000
    Posts:
    558
    Likes Received:
    0
    Location:
    Chicopee, Ma 01020
    The guage worked fine before I messed with the fuel pump. New the sending unit cost around $300 from dealer. Parts stores dosen't sell them. I used a meter on the sending unit while out and there was a fluctuation in thr ohm reading, unknown if it was ok. The next time I'll try reading it while the unit is in the tank. I shall check my egr valve. Thanks everyone for your help.
     

Share This Page