Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

fuel gauge not working!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Marshall, May 3, 2003.

  1. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    MY fuel guage om my truck stopped working all of the sudden i dont know what the problem is i checked all connections and fuses. does anyone know what might be causing this problem if so please let me know.It is a 31 gallon tank and the vehicle is an 87 Jimmy

    Thanks, Marshall
     
  2. JustHorsinArownd

    JustHorsinArownd Registered Member

    Joined:
    Mar 20, 2003
    Posts:
    77
    Likes Received:
    0
    Location:
    Flagstaff, Az.
    I'm thinkin the sender.
     
  3. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Check the wires the whole length. I had a Tree rat or a chipmunk chew up some wires on my truck and got the gage wire. They also got the return fuel line. /forums/images/graemlins/shocked.gif
     
  4. santana

    santana 1/2 ton status

    Joined:
    Jan 11, 2003
    Posts:
    1,483
    Likes Received:
    0
    Location:
    Mesa Arizona
    I had that same problem. Does it stop at about half way? If it does regardless of amount of gas, Theres a pan inside the tank that came loose causing the sender to jam up against the said pan. Just a possibility but like posted before me, Id check the wiring first before dropping the tank especially if its full.. /forums/images/graemlins/thumb.gif
     

Share This Page