Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Fuel guage sticks

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 87K54WD, Mar 23, 2000.

  1. 87K54WD

    87K54WD 1/2 ton status

    Joined:
    Mar 23, 2000
    Posts:
    105
    Likes Received:
    0
    Location:
    Texas
    Just posting this for some thoughts/ideas .... the fuel guage sticks when I get down to 1/4 of a tank left of gas. When full, it works fine just until I get to the 1/4 left mark and it just sticks there. My uncle had the fuel pump replaced about a year ago from a local shop. Maybe they screwed something up???
     
  2. Goose

    Goose 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,127
    Likes Received:
    1
    Location:
    South Central Kansas
    The fuel pump has nothing to do with how accurate your fuel gage is. Your gage is messing up or the float in the tank is sticking at the 1/4 level. Since either can be a pain to work on, start by tracing all the wires and making sure they are clean and have good contacts. There were some posts a while back about the gages. You may want to use the "Search" option on this site and look 'em up.
    Good luck fellow K5er

    the Goose
     
  3. K5experience

    K5experience Registered Member

    Joined:
    Mar 4, 2000
    Posts:
    56
    Likes Received:
    0
    Location:
    brandon florida
    Not saying this is your problem but I had the same prob and the gauge was bad
     
  4. Blazer1970

    Blazer1970 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,600
    Likes Received:
    0
    Location:
    Old Mission, MI
    Since your fuel pump hangs on the sending unit in the tank, they could have caused the problem during the fuel pump install. If something got screwed up in there, the float could be binding. In fact, if the gauge problem started at the same time that the pump was replaced, I would almost guarantee that that is what happened.

    Tim

    1970 Blazer CST 4X4 350 SM465 NP205
    1987 Suburban 4X4 350
    1988 Chevy Pickup 4X4 350
     

Share This Page