Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

fuel pump bad?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bigdaddy89, Apr 19, 2001.

  1. bigdaddy89

    bigdaddy89 1/2 ton status

    Joined:
    May 18, 2000
    Posts:
    422
    Likes Received:
    0
    Location:
    Phx, Az
    I am currenty having a problem that might be the fuel pump, but I am not for sure. It seems as if I am not getting much fuel at take off, but if I give it more gas it opens up. It gets worse after driving for a while. I have changed the filter and cleaned the injectors so far. Are there any specific signs to look for to determine a bad pump? The baffling? Is there a certain amount of voltage that has to be going to the pump? The pump has never been changed. 89/350fi/AT/118,000. Thank you for your support.

    GOT ROCKS?
     
  2. Wheels

    Wheels 1/2 ton status

    Joined:
    Aug 18, 2000
    Posts:
    638
    Likes Received:
    0
    Location:
    Native Floridian living in Oklahoma, USA
    There may be trash in the tank blocking the pickup tube.
     
  3. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    Sounds like it could be a TPS (throttle positioning sensor). They give that symptom when out of adjustment (been there done that). Pump needs 12 volts +/- I am pretty sure. Since it is TBI it is not a high pressure pump so seems unlikely it is a pump, but hey, I don't really know jack...........lol.

    Might want to check the fuel pressure if you have a gauge. Not sure of the specs but I would think TPS. Easy adjustment if you have someone with a reader. My setting for the TPS is .50-.54 (not sure what the unit of measurement is nor what it is supposed to be for a TBI).

    Let us know.

    <font color=orange>'79 - 406 TPI -<font color=orange> K5#5 - <font color=blue>See it at---&gt;<A target="_blank" HREF=http://www.blazzinor.coloradok5.com>http://www.blazzinor.coloradok5.com</A>
     
  4. Blazer79

    Blazer79 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,816
    Likes Received:
    0
    Location:
    Guatemala, Central America
    Have you replaced your oxygen sensor?

    <font color=blue>//////
    <A target="_blank" HREF=http://blazer79.coloradok5.com>http://blazer79.coloradok5.com</A>
    </font color=blue>[​IMG]
     

Share This Page