Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Fuel system problems!?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by johnnieg, Nov 21, 2002.

  1. johnnieg

    johnnieg 1/2 ton status

    Joined:
    Nov 10, 2002
    Posts:
    130
    Likes Received:
    0
    Location:
    CSU, Ft. Collins, CO
    My '88 is having a really bad time. A few days ago, I was coming home from Widefield and every once in a while the enging would cut out. Not sputtering like it's out of gas, but like the throttle is backing off. The next day it was a bit more often, then that day coming home from school it wouldn't go above 15 mph! Floored! /forums/images/graemlins/eek.gif I put in some fuel injector cleaner and it's keeping it going, but I'm curious if the injectors or the fuel filter are shot. Any ideas?
     
  2. 85HeartBurb

    85HeartBurb 1/2 ton status

    Joined:
    Jan 10, 2002
    Posts:
    735
    Likes Received:
    0
    Location:
    Temecula, south
    i had a similar prob and my pos coil wire was frayed so it kept cutting out! /forums/images/graemlins/k5.gif /forums/images/graemlins/usaflag.gif
     
  3. johnnieg

    johnnieg 1/2 ton status

    Joined:
    Nov 10, 2002
    Posts:
    130
    Likes Received:
    0
    Location:
    CSU, Ft. Collins, CO
    maybe, but when i put the injector cleaner in, it started working fine. How could a fuel additive fix a messed up wire? /forums/images/graemlins/confused.gif
     

Share This Page