Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Gas Gauge is pretty screwed...

Discussion in 'The Garage' started by RustBuket, Feb 8, 2004.

  1. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
    Ok, so I put a hole in my tank and had to drop it/repair it/reinstall. After the reinstallation, the gas gauge is acting really weird. It jumps up to about the 3 oclock position sometimes and everytime I start my truck up I get a different reading so I don't know which is right! What wire did I not connect right? The red one that goes to the sender on top? Or is there another wire that I just didn't see all together? A ground maybe? /forums/images/graemlins/1zhelp.gif
     
  2. rcpilot

    rcpilot 1/2 ton status

    Joined:
    Feb 22, 2002
    Posts:
    507
    Likes Received:
    0
    Location:
    Central Cali
    There is a ground that needs to be connected...it usually runs from the frame/crossmember in front of the tank to the ground tab on the sending unit.. if ya only hooked up opne wire then ya missed one...
     
  3. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
    Well then that is most likely my problem. And i bet the whats happening is the ground is bouncing off the tank and sort of making connections sometimes giving me the messed gauge...
     
  4. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
    Do I have to drop the tank to reattach the ground wire?
     
  5. RustBuket

    RustBuket 1/2 ton status

    Joined:
    Feb 21, 2003
    Posts:
    1,618
    Likes Received:
    0
    Location:
    Saskatchewan, Canada
  6. shaun

    shaun 1/2 ton status

    Joined:
    Apr 22, 2003
    Posts:
    745
    Likes Received:
    0
    Pleaselet me know if that helps b/c i bought a 90 jimmy and it does the same thing. Sometimes it wont move sometimes it will. It jumps around to. And it moves every time I restart the truck. WTF??? /forums/images/graemlins/eek.gif
     
  7. husurddy

    husurddy 1/2 ton status

    Joined:
    Jul 28, 2001
    Posts:
    108
    Likes Received:
    0
    Location:
    Snow Hill, Maryland, go east \'till you hit water
    I had the same problem but it wasn't a wire. Mine turned out to be the plastic tub in the tank had come undone and was hitting my sending unit. Before I fixed it I would hear a slight banging noise in the tank when I first came to a stop. I used gas tank sealer on the nuts that press down and hold the tub in place and has worked great for two years.
     

Share This Page