Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Gas Guage problems!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by TXsizeK5, Sep 17, 2002.

  1. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    ok before... when my tank is full my gauge would read half. I got my new engine and the shop disconceted the unit. it would read all the way past full no matter how much gas was in. I got a new sender unit and it does the SAME thing... reads about half way when full. I dont know whats up... think it could be the gauge? Thanks
     
  2. Muddytazz

    Muddytazz 1 ton status

    Joined:
    Jun 30, 2002
    Posts:
    20,073
    Likes Received:
    0
    Location:
    Salem, Or.
    mine did the same thing...check the connection behind the gauge...all i did was tighten up the nuts that held the gauge in and its worked perfectly ever since.
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Hopefully you didn't send that old one in for that $30 core charge if it wasn't faulty!
     
  4. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    you have what sounds like a bad ground someplace try making a new ground wire at the tank and check your wires all the way from the tank up to the gage
     
  5. k5ntexas

    k5ntexas 1/2 ton status

    Joined:
    Oct 29, 2001
    Posts:
    2,517
    Likes Received:
    0
    Location:
    corpus christi, texas.
    he bought the sender unit from a ck5 member i think. i doubt they'd have a core charge. LOL. later.

    jacob
     

Share This Page