Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Good Vibrations...not!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by TDAWG1, Jan 18, 2006.

  1. TDAWG1

    TDAWG1 1/2 ton status Premium Member

    Joined:
    Jan 18, 2005
    Posts:
    2,836
    Likes Received:
    8
    Location:
    Grand Junction, Crawlorado
    I have a serious vibation from the under side of my JIMMY. Whats the deal. My U joints apear to be fine. the ones on the rear shaft are new. Truck was driving fine then one day about 3 weeks ago. This vibration starts. I regreased all greasable areas That really helped in the front shaft which was dry. YIKES!
    I am waiting to fix some of the under problems because I am hoping to get my lift soon. Though the longer I wait to find this problem the more money I'll end up spending. Which also brings me to ask. does anyone know a good place to get some drive line work done in Grand Junction? I'll need it when I get my lift.Thanx 4 da help all and happy new year to ya.:bow: :haha: :doah: :wink1: :laugh: :whistle: :tongue1: :ears: :dunno: :k5: :1zhelp:
     
  2. 89-Blazer

    89-Blazer Registered Member

    Joined:
    Nov 14, 2005
    Posts:
    19
    Likes Received:
    0
    Location:
    Vancouver, WA
    Pinion bearings might be failing. Is the yoke still good and snug or does it wobble in the housing?

    Mike
     
  3. TDAWG1

    TDAWG1 1/2 ton status Premium Member

    Joined:
    Jan 18, 2005
    Posts:
    2,836
    Likes Received:
    8
    Location:
    Grand Junction, Crawlorado
    Good thought thanx, but know I just got new bearings. I guess I'll keep looking.
     
  4. oatsk5

    oatsk5 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Aug 18, 2002
    Posts:
    1,724
    Likes Received:
    8
    Location:
    Grand junction CO
    hey ill call you
     
  5. TheColonel

    TheColonel Registered Member

    Joined:
    Jan 22, 2006
    Posts:
    17
    Likes Received:
    0
    Location:
    SC
    Did you check to make sure all of the weights on the drive shaft are still intact? I had a similar problem and found out that my drive shaft had a weight that fell off causing vibrations..
     
  6. TDAWG1

    TDAWG1 1/2 ton status Premium Member

    Joined:
    Jan 18, 2005
    Posts:
    2,836
    Likes Received:
    8
    Location:
    Grand Junction, Crawlorado
    That would be great!
     
  7. TDAWG1

    TDAWG1 1/2 ton status Premium Member

    Joined:
    Jan 18, 2005
    Posts:
    2,836
    Likes Received:
    8
    Location:
    Grand Junction, Crawlorado
    i'll check the weights thanx
     
  8. jms

    jms 1/2 ton status Author

    Joined:
    Jan 24, 2001
    Posts:
    1,683
    Likes Received:
    0
    Location:
    --
    Check the bolts that hold the adapter between tranny and t'case to the rubber mount at the X-member. A while ago those bolts on my truck had elected to go their own way...
     
  9. oatsk5

    oatsk5 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Aug 18, 2002
    Posts:
    1,724
    Likes Received:
    8
    Location:
    Grand junction CO
    i went over and im thinking part of it mabe a bad trany mount
     
  10. TDAWG1

    TDAWG1 1/2 ton status Premium Member

    Joined:
    Jan 18, 2005
    Posts:
    2,836
    Likes Received:
    8
    Location:
    Grand Junction, Crawlorado
    Yup Thanx for coming over. that is a great place to start. Tanx 4 da help.
     

Share This Page