Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

got a bit of a problem with engine swap in a safari minivan

Discussion in 'Other Rides' started by big83chevy4x4, Nov 6, 2004.

  1. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    i have a 2wd 94 safari with a vortec 4.3 and a 4L60E tranny. the van has 350,000 miles on it and we can't figure out the problem with the tranny. the body is just too rust free to junk it, all it needs is a motor and tranny.

    we got a 2wd 92 s10 blazer with the vortec 4.3 and a 700r4 that we are going to swap into van.

    engine, tranny are out of both as well as computers and wiring harness on both. my plan was to just put the harness and the computer from the blaser in the van and be done with it. but after i compared the two harnesses, they are WAY too different. its not the plugs that go onto the engine, but the ones that go into the other harnesses. the blazer harness goes to the computer and the the fuse box, and the van harness goes to the computer but plugs into the light harness that goes to the fuse box.

    my last resort is to dissasemble both harnesses and assemble 1 harness that will work for me. i don't really want to do that.

    the computer from the van cotrols the tranny and i don't know if the engine will act differently seeing that it will get no signals from the tranny.

    on the blazer, the lockup is controled by the computer and i wanna keep it that way. i want it to look factory

    im not sure if they ever put a vortec 4.3 and a 700r4 together in these vans, if they did, am i gonna have the same problems?

    if i can get a factory harness it would have to be from a 92, in 93 they started the 4L60E and in 92 is when they started making the vortec 4.3, but not everything in 92 got the vortec engine.

    any help? anyone have a harness that will work for me or know of someone that will make me one cheap?
     
  2. Z3PR

    Z3PR Banned

    Joined:
    Mar 30, 2002
    Posts:
    19,217
    Likes Received:
    0
    Location:
    Everywhere
    That sounds like a big headacke. I'd check the local salvage yards for a stock replacement.
     
  3. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    all the junkyards around here crushed just about everything they had, so i dought i will find what im looking for, but its worth a shot calling.
     
  4. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
  5. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    How differrent are the 4.3s? Both vortec? Why not look for a 4l60E and bolt that to the S10 4.3 (since the 700 wont work)? Id think 4l60es would be somewhat easy to find.
     
  6. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    both are vortec 4.3, they are identicle, right down to the sensors.

    i have a 4L60E but we are chasing (what i think are) electrical problems and just don't want to deal with it anymore. we have dumped too much money in this one and don't wanna do another. i could rebuild it but would rather have a 700r4. i wouldn't trust a junkyard auto, if i get one id rebuild it, but like i said i have one.
     

Share This Page