Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got an 87 Chevy not getting any fuel!!!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by blazen_md, Oct 30, 2002.

  1. blazen_md

    blazen_md 1/2 ton status

    Joined:
    Aug 20, 2001
    Posts:
    129
    Likes Received:
    0
    Location:
    MD
    I have an 87 chevy 1/2 ton 4x4 with dual tanks it has a 350 tbi motor. I replaced the fuel selector valve the switch and the oil pressure guage since on some of them it acts as a cutoff. It only runs if you hold the switch on the tank selector in. Anyone else ever had this problem.
     
  2. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    That's a weird one. Most of us are running K5's so no tank selector. Hopefully somebody has a truck and has and answer for this sort of problem.
     
  3. blazen_md

    blazen_md 1/2 ton status

    Joined:
    Aug 20, 2001
    Posts:
    129
    Likes Received:
    0
    Location:
    MD
    Yeah I know this is for a truck and most of you had k5's including myself but just thought I would give it a shot. No big deal. Thanks
     
  4. Wraparound

    Wraparound Registered Member

    Joined:
    Feb 23, 2000
    Posts:
    91
    Likes Received:
    0
    Location:
    Sacramento
    Got the same truck but I haven't had that prob yet.
     
  5. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    Change the switch or rebuild it, it should be a weak spring inside.
     

Share This Page