Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got an isuzu question you guys might be able to answer...

Discussion in 'The Garage' started by MEPR, Jan 12, 2004.

  1. MEPR

    MEPR 1/2 ton status

    Joined:
    Oct 21, 2002
    Posts:
    1,546
    Likes Received:
    0
    Location:
    McChord AFB
    Alrighty, my troopers motor is a 2.6L inline 4 multi port fuel injection. What might cause one cylinder to be washed whith fuel. Is it just the injector or could there be issues whith stuff like the TPS MAF sensor and the like? Thanks for any help.
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    I would doubt it. If fairly new and sequential injection, perhaps, but even then, the ECM or PCM tells the injector how long to squirt, if one cylinder was screwed up, all would be, since all the sensors "see" the entire engine, not one cylinder.

    Only thing I can think of if it WASN'T the injector, would be a wiring issue causing the injector to constantly pump fuel, but that seems unlikely. Fuel economy would be horrid I'm sure.

    You can have injectors "cleaned" for something like $25 each, (perhaps less depending on where you are) and all places that do this test the injectors, so they will tell you if its bad. I think you can actually test the injector yourself with a multimeter, but can't recall exactly what you look for.
     
  3. MEPR

    MEPR 1/2 ton status

    Joined:
    Oct 21, 2002
    Posts:
    1,546
    Likes Received:
    0
    Location:
    McChord AFB
    alrighty thanks, i guess ill have to call around and find a place that tests and cleans injectors then.
     
  4. brando

    brando Registered Member

    Joined:
    Jan 10, 2004
    Posts:
    10
    Likes Received:
    0
    Location:
    Gering Nebraska
    I would check to see if you have any spark going to that cyl. make sure that there is spark at the plug that is in the engine and check the wire, cap and rotor. The spark plug you have in there may not be any good same goes for the other parts as well. Check compression too.
     
  5. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,097
    Likes Received:
    144
    Location:
    california
    There is a mini truck forum on CK5, little motors are probably discussed there on a regular basis. /forums/images/graemlins/deal.gif/forums/images/graemlins/thumb.gif
     
  6. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    I don't think there is anything wrong with someone posting a general engine question in this forum.

    Sorry, but I'm going to be running TPI, and there are others as well, the answer or solution to his problem may be as much help to us as it is anyone with an Isuzu.

    "this forum is for the general discussion of almost any truck-related topic."

    Somehow I think discussing/troubleshooting technology that is already being used on some of our trucks falls within that phrases intent.
     

Share This Page