Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got my 77 running! Video clips!

Discussion in 'The Garage' started by Russell, Jan 17, 2006.

  1. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,925
    Likes Received:
    336
    Location:
    Fort McMurray, Alberta
  2. muddybuddy

    muddybuddy 3/4 ton status

    Joined:
    Jan 29, 2004
    Posts:
    8,933
    Likes Received:
    1
    Location:
    Fairfax Station VA
    looks like you took one out of branndonc's book with the video. im sure someone will chim in with whats wrong
     
  3. 2High4U

    2High4U 1/2 ton status

    Joined:
    Aug 20, 2005
    Posts:
    542
    Likes Received:
    0
    Location:
    Felton Pennsylvania
    sounds to me like a broken rod.
     
  4. BranndonC

    BranndonC 3/4 ton status

    Joined:
    Mar 18, 2002
    Posts:
    8,591
    Likes Received:
    0
    Location:
    Anaheim, Ca
    nice vid! lol too bad about the knock though
     
  5. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    that sounds to me like a thrown rod or a bearing
     
  6. captaininsano

    captaininsano 1/2 ton status

    Joined:
    May 4, 2004
    Posts:
    233
    Likes Received:
    0
    Location:
    Bay Area, CA
    hope you don't plan on re-using that crank....
     
  7. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,925
    Likes Received:
    336
    Location:
    Fort McMurray, Alberta
    I'm really hoping it is a shot bearing. If its a busted rod, I can't easily fix it then =/

    I'm gonna buy one of those master rebuild kits, cept get the cam stuff replaced with a set of flat tops for it. Do a quick balance job, and re-install it with fresh rings, new seals, bearings and a nice cam I'm not using.
     
  8. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,178
    Likes Received:
    1,387
    Location:
    E-town baby!
    I had a knock like that with my old 355. I installed the dust shield for the 465 a little wrong and the offset on the crank was hitting the tab on the dust shield once per rev. I almost pulled it to send to sbc heaven before I found what was wrong...

    Rene
     
  9. Russell

    Russell LB7 Tahoe Status Premium Member GMOTM Winner

    Joined:
    Jun 23, 2000
    Posts:
    7,925
    Likes Received:
    336
    Location:
    Fort McMurray, Alberta
    I'm gonna take a closer look at the flywheel area tommorow, just incase, but I'm thinkin it's a rod knock :(
     

Share This Page