Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got my new motor in!!

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by K5krazy, May 6, 2001.

  1. K5krazy

    K5krazy Registered Member

    Joined:
    Aug 22, 2000
    Posts:
    13
    Likes Received:
    0
    Location:
    Petaluma, CA
    Finally after months of working and waiting on the machine shop, my 383 is in and running! Boy what a difference a new motor makes too! Now I'm just waiting for the Blazerfest so I can have some fun with other Blazer enthusiasts!
     
  2. K5Buckeye

    K5Buckeye Registered Member

    Joined:
    Mar 5, 2001
    Posts:
    75
    Likes Received:
    0
    Location:
    WA
    Details, details!! We need details!! What are the spec's?

    1972 K5
     
  3. Steve_Chin

    Steve_Chin 1/2 ton status

    Joined:
    Mar 6, 2001
    Posts:
    1,126
    Likes Received:
    0
    Location:
    Foster City, CA, USA
    Congratulations, and break it in nice... Don't forget to do a LOT of oil and filter changes to get all that grit out of the engine. I wrote a quickie article on how to properly break-in a cam and bed the rings to the cylinder walls: <A target="_blank" HREF=http://www.geocities.com/MotorCity/Downs/1963/Articles/break-in.html>http://www.geocities.com/MotorCity/Downs/1963/Articles/break-in.html</A>
     

Share This Page