Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Got stuck, now almost no forward gears (turbo 350 / np203)

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by cjk3500, Feb 2, 2003.

  1. cjk3500

    cjk3500 Registered Member

    Joined:
    Sep 10, 2001
    Posts:
    15
    Likes Received:
    0
    Location:
    Blairstown, New Jersey
    I got stuck on the side of a snowy hill /forums/images/graemlins/angryfire.gif with my 77 K10 with a turbo 350 and np203. I had all four wheels spinning pretty good and couldn't get up the hill. I went back the next day after the snow had gone down some and it wouldn't even spin the tires anymore. It didn't even seem to load up when I put it in gear. I pulled the truck out with my K3500 /forums/images/graemlins/crewcab.gif but I had no forward or reverse. I checked the fluid and the linkages and everything looks fine. After some moving the shifters back and forth I now have normal reverse, but I have to put it in low gear to even be able to creep forward (with the engine revving pretty high). Any ideas on what happened or what to look for?

    Thanks in advance,
    Chris
     
  2. Ryan2286

    Ryan2286 Registered Member

    Joined:
    Nov 7, 2002
    Posts:
    32
    Likes Received:
    0
    Location:
    South Suburbs of Chicago
    I'm going to say its probably a burned tranny. Have you checked your fluid? if its brown or black and smells like burning you know its the tranny. I don't think it woul.d be the T-case unless you hear grinding and whatnot, so its most likely the transmission.
     
  3. Mikeyg79

    Mikeyg79 Registered Member

    Joined:
    Aug 3, 2002
    Posts:
    83
    Likes Received:
    0
    Sounds like another roasted TH350 to me.
    Gotta love the SM465..
     
  4. K5Psycho

    K5Psycho Registered Member

    Joined:
    Jan 6, 2002
    Posts:
    55
    Likes Received:
    0
    Location:
    FL, USA
    i lost 3rd and 4th on my 700r4 in 4H doing mudding
     
  5. wrathORC

    wrathORC 1/2 ton status

    Joined:
    Apr 27, 2002
    Posts:
    908
    Likes Received:
    0
    Location:
    Hancock, MI
    Another turbo 350 bites the dust. In my opinion they're worse than a 700R4. There's a reason why I have 3 dead TH350s laying around. And I've never run any of them, they were in trucks I bought.

    You've probably got enough smoked clutches to cure a ham.
     
  6. cjk3500

    cjk3500 Registered Member

    Joined:
    Sep 10, 2001
    Posts:
    15
    Likes Received:
    0
    Location:
    Blairstown, New Jersey
    Thanks for the replies. I checked the fluid again and it is burnt. So much for this truck, It has soo much rust and now a bad trans, any one need a parts truck in NJ? /forums/images/graemlins/wink.gif
     

Share This Page